Mercurial > bins
comparison debian/patches/11_check_template_style @ 4:c5749e43b1d7
Adding debian files (to original 1.1.29)
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Wed, 15 Oct 2008 23:35:35 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
0:a84c32f131df | 4:c5749e43b1d7 |
---|---|
1 #! /bin/sh /usr/share/dpatch/dpatch-run | |
2 ## 11_check_template_style.dpatch by Martin Michlmayr <tbm@cyrius.com> | |
3 ## | |
4 ## DP: Check if template style exists before processing images [#308114] | |
5 | |
6 @DPATCH@ | |
7 --- bins-1.1.29.orig/bins | |
8 +++ bins-1.1.29/bins | |
9 @@ -1092,6 +1092,11 @@ | |
10 exit 1; | |
11 } | |
12 | |
13 + if (! scalar templateDirs($configHash)) { | |
14 + print "Cannot find template style '", $configHash->{templateStyle}, "'\n"; | |
15 + exit 1; | |
16 + } | |
17 + | |
18 $picdir = $ARGV[0]; | |
19 $albumdir = $ARGV[1]; | |
20 |