comparison debian/patches/20_bins-syscall @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 20_bins-1.1.29-syscall.dpatch by <rousseau@localhost.localdomain>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
6
7 @DPATCH@
8 --- bins-1.1.29.orig/bins
9 +++ bins-1.1.29/bins
10 @@ -3546,13 +3546,14 @@
11 $newpath = "$picdir$origName";
12 }
13 beVerboseN("Linking from $albumdir$newName to $newpath... ", 2);
14 - system("ln", "-sf", $newpath, "$albumdir$newName") == 0
15 + unlink("$albumdir$newName");
16 + symlink($newpath, "$albumdir$newName") == 1
17 or die("\nCannot link $albumdir$newName to $newpath: $?");
18 # the original file may be r/o but we don't have to modify it
19 # but it must be readable by the http deamon
20 if ($configHash->{updateOriginalPerms})
21 {
22 - system("chmod", "a+r", "$picdir$origName") == 0
23 + chmod(0644, "$picdir$origName") == 1
24 or die("\nCannot set read permission on $albumdir$newName: $?");
25 }
26 beVerboseN("done.", 2);
27 @@ -3563,7 +3564,7 @@
28 system("cp", "-p", "$picdir$origName", "$albumdir$newName") == 0
29 or die("\nCannot copy $picdir$origName to $albumdir$newName: $?");
30 # make it writable in case $origName was r/o
31 - system("chmod", "u+w,a+r", "$albumdir$newName") == 0
32 + chmod(0644, "$albumdir$newName") == 1
33 or die("\nCannot set write permission on $albumdir$newName: $?");
34 beVerboseN("done.", 2);
35 return 1;