comparison debian/patches/22_bins-hash-ref @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 22_hash_ref.dpatch by <rousseau@imac.maison.bogus>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Closes: #481662 bins: Crashes mid-album
6
7 @DPATCH@
8 --- bins-1.1.29.orig/bins
9 +++ bins-1.1.29/bins
10 @@ -3750,8 +3750,8 @@
11
12 my @descTable;
13 foreach my $tagName (@mainFields) {
14 - if (${%$hashref}{$tagName}) {
15 - my $value=${%$hashref}{$tagName};
16 + if (${$hashref}{$tagName}) {
17 + my $value=${$hashref}{$tagName};
18 $value =~ s/'/&#39;/g ; # in case it's used in javascript code
19 push @descTable, {DESC_FIELD_NAME => $fields{$tagName}->{'Name'},
20 DESC_FIELD_VALUE => $value,