comparison debian/rules @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 #LANGS=de fr pl
9
10 LFILES=$(subst intl/,,$(wildcard intl/??.mo))
11 LANGS=$(LFILES:.mo=)
12 GUILFILES=$(subst intl/gui-,,$(wildcard intl/gui-??.mo))
13 GUILANGS=$(GUILFILES:.mo=)
14
15 CFLAGS += -g
16 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
17 INSTALL_PROGRAM += -s
18 endif
19 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21 else
22 CFLAGS += -O2
23 endif
24
25
26 version := $(shell dpkg-parsechangelog | \
27 sed -ne 's/^Version: *\([0-9]\+:\)*//p')
28
29 tag:
30 cvs tag -c -F $(subst .,_,debian_version_$(version))
31
32 include /usr/share/quilt/quilt.make
33
34 configure: configure-stamp
35 configure-stamp:
36 dh_testdir
37 # Add here commands to configure the package.
38
39 touch configure-stamp
40
41 build: build-stamp
42 build-stamp: patch configure-stamp
43 dh_testdir
44
45 touch build-stamp
46
47 clean: unpatch
48 dh_testdir
49 dh_testroot
50
51 if [ -f doc/bins.1.bak ]; then \
52 mv doc/bins.1.bak doc/bins.1; fi
53 dh_clean
54
55 install: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
60
61 # backup original manpages
62 mv doc/bins.1 doc/bins.1.bak
63
64 # regeneate modified manpages
65 docbook-to-man doc/bins.sgml > doc/bins.1
66
67 # Add here commands to install the package into debian/bins.
68 echo | ( DESTDIR=`pwd`/debian/bins PREFIX=/usr ./install.sh )
69 install -m 0755 tools/bins_cleanupgallery debian/bins/usr/bin/
70
71 install -m 0755 tools/add_num_prefix debian/bins/usr/share/doc/bins/examples/
72 install -m 0755 tools/anti_bins debian/bins/usr/share/doc/bins/examples/
73 install -m 0755 tools/bins_addtext debian/bins/usr/share/doc/bins/examples/
74 install -m 0755 tools/bins_txt2xml debian/bins/usr/share/doc/bins/examples/
75 install -m 0755 tools/remove_num_prefix debian/bins/usr/share/doc/bins/examples/
76
77 # install HTML documentation
78 cp doc/*html debian/bins/usr/share/doc/bins/
79
80 # remove bins-edit-gui since it depends on Gtk+ 1.x
81 find debian -name "bins-edit-gui*" -exec rm {} \;
82
83 # Build architecture-independent files here.
84 binary-indep: build install
85 dh_testdir
86 dh_testroot
87 # dh_installdebconf
88 dh_installdocs
89 dh_installexamples
90 # dh_installmenu
91 # dh_installlogrotate
92 # dh_installemacsen
93 # dh_installpam
94 # dh_installmime
95 # dh_installinit
96 # dh_installcron
97 dh_installman
98 # dh_installinfo
99 # dh_undocumented
100 dh_installchangelogs ChangeLog
101 # dh_link
102 # dh_strip
103 dh_compress
104 dh_fixperms
105 # dh_makeshlibs
106 dh_installdeb
107 # dh_perl
108 # dh_shlibdeps
109 dh_gencontrol
110 dh_md5sums
111 dh_builddeb
112
113 # Build architecture-dependent files here.
114 binary-arch: build install
115 # We have nothing to do
116
117 binary: binary-indep binary-arch
118 .PHONY: build clean binary-indep binary-arch binary install configure
119