view debian/patches/11_check_template_style @ 9:0f248ad86f9f 1.1.29.e2

bins_edit: try to get encoding stuff right, move it into main
author Peter Gervai <grin@grin.hu>
date Thu, 16 Oct 2008 00:11:14 +0200
parents c5749e43b1d7
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 11_check_template_style.dpatch by Martin Michlmayr <tbm@cyrius.com>
##
## DP: Check if template style exists before processing images [#308114]

@DPATCH@
--- bins-1.1.29.orig/bins
+++ bins-1.1.29/bins
@@ -1092,6 +1092,11 @@
         exit 1;
     }
 
+    if (! scalar templateDirs($configHash)) {
+        print "Cannot find template style '", $configHash->{templateStyle}, "'\n";
+        exit 1;
+    }
+
     $picdir = $ARGV[0];
     $albumdir = $ARGV[1];