view debian/patches/11_check_template_style @ 6:3021deef1599

Encoding related fixes * chomp encoding string * reformat else (seems someone hacked it in) * debug print encoding * do not use :utf8 binmode ("re-encode") on written file if the input is _already_ UTF-8
author Peter Gervai <grin@grin.hu>
date Thu, 16 Oct 2008 00:02:14 +0200
parents c5749e43b1d7
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 11_check_template_style.dpatch by Martin Michlmayr <tbm@cyrius.com>
##
## DP: Check if template style exists before processing images [#308114]

@DPATCH@
--- bins-1.1.29.orig/bins
+++ bins-1.1.29/bins
@@ -1092,6 +1092,11 @@
         exit 1;
     }
 
+    if (! scalar templateDirs($configHash)) {
+        print "Cannot find template style '", $configHash->{templateStyle}, "'\n";
+        exit 1;
+    }
+
     $picdir = $ARGV[0];
     $albumdir = $ARGV[1];