Mercurial > bins
view debian/patches/23_bashism @ 6:3021deef1599
Encoding related fixes
* chomp encoding string
* reformat else (seems someone hacked it in)
* debug print encoding
* do not use :utf8 binmode ("re-encode") on written file if the input is _already_ UTF-8
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Thu, 16 Oct 2008 00:02:14 +0200 |
parents | c5749e43b1d7 |
children |
line wrap: on
line source
--- bins-1.1.29.orig/tools/anti_bins +++ bins-1.1.29/tools/anti_bins @@ -47,7 +47,7 @@ exit 2 fi -if [[ $CONFIGURATION_IS_OK == 0 ]] ; then +if [ $CONFIGURATION_IS_OK = 0 ] ; then echo "Edit this script to set configuration variables." exit 1 fi --- bins-1.1.29.orig/tools/add_num_prefix +++ bins-1.1.29/tools/add_num_prefix @@ -1,4 +1,4 @@ -#!/bin/sh +#!/bin/bash # Add a numeric prefix starting at $1, incrementing by $2 on $3..$n files