view debian/patches/09_fix_wrong_relpath @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 09_fix_wrong_relpath.dpatch by Martin Michlmayr <tbm@cyrius.com>
##
## DP: Fix a off by one in relpath() [#334088]

@DPATCH@
--- bins-1.1.29.orig/bins
+++ bins-1.1.29/bins
@@ -1151,7 +1151,7 @@
     my $l2 = length($p2);
 
     my $cl = cls($p1, $p2);
-
+    $cl-- if (substr($p2, $cl-1, 1) ne "/");
     my $p2r = substr( $p2, $cl, $l2);
 
     my $p1dc = 0;