view debian/patches/13_locale_encoding @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 13_locale_encoding.dpatch by J?r?me Sautret
##
## DP: convert latin-1 output to locale [#308111]

@DPATCH@

--- bins-1.1.29.orig/bins
+++ bins-1.1.29/bins
@@ -952,13 +952,23 @@
 
 sub write_htaccess;
 
-print "\nBINS Photo Album 1.1.29 (http://bins.sautret.org/)\n";
-print "Copyright ? 2001-2004 J?r?me Sautret (Jerome\@Sautret.org)\n";
-print "Some parts of code:\n";
-print "Copyright ? 2000 Brendan McMahan (mcmahahb\@whitman.edu)\n";
-print "Copyright ?      John Moose (moosejc\@muohio.edu)\n\n";
-print "This is free software with ABSOLUTELY NO WARRANTY.\n";
-print "See COPYING file for details.\n\n";
+my $copyright=<<END;
+BINS Photo Album 1.1.29 (http://bins.sautret.org/)
+Copyright ? 2001-2004 J?r?me Sautret (Jerome\@Sautret.org)
+Some parts of code:
+Copyright ? 2000 Brendan McMahan (mcmahahb\@whitman.edu)
+Copyright ?      John Moose (moosejc\@muohio.edu)
+
+This is free software with ABSOLUTELY NO WARRANTY.
+See COPYING file for details.
+
+END
+
+my $latin2localConverter;
+$latin2localConverter = Text::Iconv->new('latin1',
+$defaultConfig{defaultEncoding});
+$copyright = $latin2localConverter->convert($copyright);
+print $copyright;
 
 # EVG (Evil Global Variables)
 # Some on them should be moved to the config hash so they can be