Mercurial > bins
view debian/patches/17_bins @ 4:c5749e43b1d7
Adding debian files (to original 1.1.29)
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Wed, 15 Oct 2008 23:35:35 +0200 |
parents | |
children |
line wrap: on
line source
#! /bin/sh /usr/share/dpatch/dpatch-run ## 17_bin.dpatch by <rousseau@localhost.localdomain> ## ## All lines beginning with `## DP:' are a description of the patch. ## DP: No description. @DPATCH@ --- bins-1.1.29.orig/bins +++ bins-1.1.29/bins @@ -547,7 +547,7 @@ "date" => { Name => _("Date"), EXIF => "DateTimeOriginal", - Transform => '$_ = local2html(strftime $configHash->{dateString}, gmtime str2time "$_") if str2time "$_"', + Transform => '$_ = local2html(strftime $configHash->{dateString}, localtime str2time "$_") if str2time "$_"', # Alternatively, you could use regex substitution: # English version is yyyy:mm:dd hh:mm:ss to yyyy/mm/dd hh:mm:ss : # Transform => 's%^(\\d+):(\\d+):(\\d+) (.*)$%\$1/\$2/\$3 \$4%',