Mercurial > bins
view debian/patches/21_bins-trim @ 4:c5749e43b1d7
Adding debian files (to original 1.1.29)
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Wed, 15 Oct 2008 23:35:35 +0200 |
parents | |
children |
line wrap: on
line source
#! /bin/sh /usr/share/dpatch/dpatch-run ## 21_bins-trim.dpatch by <rousseau@imac.maison.bogus> ## ## All lines beginning with `## DP:' are a description of the patch. ## DP: add -trim argument to jpegtran. ## DP: Closes: #284157: bins: avoidable jpegtran image corruption @DPATCH@ --- bins-1.1.29.orig/bins +++ bins-1.1.29/bins @@ -4894,7 +4894,7 @@ if ($rotateJPEG eq "none") { beVerbose("\n Looking for a JPEG rotation utility (jpegtran)... ", 3); if (commandAvailable("jpegtran")) { - $rotateJPEG = 'jpegtran -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; + $rotateJPEG = 'jpegtran -trim -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; beVerboseN(" found jpegtran.", 3); } elsif (commandAvailable("jpegtran-mmx")) { $rotateJPEG = 'jpegtran-mmx -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; @@ -5001,7 +5001,7 @@ if ($progressifyJPEG eq "none") { beVerbose("\n Looking for a progressive JPEG utility (jpegtran)... ", 3); if (commandAvailable("jpegtran")) { - $progressifyJPEG = 'jpegtran -copy all -progressive -outfile "%s" "%s"'; + $progressifyJPEG = 'jpegtran -trim -copy all -progressive -outfile "%s" "%s"'; beVerboseN(" found jpegtran.", 3); } else { $progressifyJPEG = "";