Mercurial > bins
view debian/patches/10_symlinks_movies @ 11:8b62360dc2a5 default tip
Adding notes, cloning edit-gui
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Sun, 02 Nov 2008 16:29:52 +0100 |
parents | c5749e43b1d7 |
children |
line wrap: on
line source
#! /bin/sh /usr/share/dpatch/dpatch-run ## 10_symlinks_movies.dpatch by Martin Michlmayr <tbm@cyrius.com> ## ## DP: Support linkInsteadOfCopy for movies [#334064] @DPATCH@ --- bins-1.1.29.orig/bins +++ bins-1.1.29/bins @@ -1849,7 +1849,20 @@ my $from="$picdir$album$fileInAlbum"; my $to="$albumdir$album$fileInAlbum"; if ( ! -f $to ) { - `cp -p "$from" "$to"`; + if ($configHash->{linkInsteadOfCopy}) { + my $newpath; + if ($configHash->{linkRelative}) { + $newpath = relpath($to, $from); + } else { + $newpath = $from; + } + beVerboseN("Linking from $to to $newpath...", 2); + system("ln", "-sf", $newpath, $to) == 0 + or die("\nCannot link $to to $newpath: $?"); + } else { + beVerboseN("Copying from $from to $to...", 2); + `cp -p "$from" "$to"`; + } } } }