comparison debian/dcc-milter.postinst @ 2:f6716cb00029

Replace buggy stuff in deb dir, never make phone calls while working
author Peter Gervai <grin@grin.hu>
date Tue, 10 Mar 2009 14:29:12 +0100
parents
children
comparison
equal deleted inserted replaced
1:9b8d79ac0dc3 2:f6716cb00029
1 #! /bin/sh
2 # postinst script for dcc
3 #
4 # see: dh_installdeb(1)
5
6 set +e
7
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # <new-version>
13 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
14 # <failed-install-package> <version> `removing'
15 # <conflicting-package> <version>
16 # for details, see http://www.debian.org/doc/debian-policy/ or
17 # the debian-policy package
18 #
19 # quoting from the policy:
20 # Any necessary prompting should almost always be confined to the
21 # post-installation script, and should be protected with a conditional
22 # so that unnecessary prompting doesn't happen if a package's
23 # installation fails and the `postinst' is called with `abort-upgrade',
24 # `abort-remove' or `abort-deconfigure'.
25
26 case "$1" in
27 configure)
28 if [ -x /usr/sbin/dccm ]; then
29 chown dcc:dcc /usr/sbin/dccm
30 chmod 04755 /usr/sbin/dccm
31 fi
32
33 ;;
34
35 abort-upgrade|abort-remove|abort-deconfigure)
36
37 ;;
38
39 *)
40 echo "postinst called with unknown argument \`$1'" >&2
41 exit 1
42 ;;
43 esac
44
45 # dh_installdeb will replace this with shell code automatically
46 # generated by other debhelper scripts.
47
48 #DEBHELPER#
49
50 exit 0
51
52