view debian/dcc-client.postinst.diff @ 1:9b8d79ac0dc3

blindly adding debian patch for old version
author Peter Gervai <grin@grin.hu>
date Tue, 10 Mar 2009 14:25:08 +0100
parents
children
line wrap: on
line source

--- dcc-1.2.74.orig/debian/dcc-client.postinst
+++ dcc-1.2.74/debian/dcc-client.postinst
@@ -0,0 +1,56 @@
+#! /bin/sh
+# postinst script for dcc
+#
+# see: dh_installdeb(1)
+
+set +e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+#
+# quoting from the policy:
+#     Any necessary prompting should almost always be confined to the
+#     post-installation script, and should be protected with a conditional
+#     so that unnecessary prompting doesn't happen if a package's
+#     installation fails and the `postinst' is called with `abort-upgrade',
+#     `abort-remove' or `abort-deconfigure'.
+
+case "$1" in
+    configure)
+	if [ -x /usr/bin/dccproc ]; then
+		chown dcc:dcc /usr/bin/dccproc
+		chmod 04755 /usr/bin/dccproc
+	fi
+	if [ -x /usr/sbin/dccifd ]; then
+		chown dcc:dcc /usr/sbin/dccifd
+		chmod 04755 /usr/sbin/dccifd
+	fi
+	
+    ;;
+
+    abort-upgrade|abort-remove|abort-deconfigure)
+
+    ;;
+
+    *)
+        echo "postinst called with unknown argument \`$1'" >&2
+        exit 1
+    ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+