comparison debian/patches/09_fix_wrong_relpath @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 09_fix_wrong_relpath.dpatch by Martin Michlmayr <tbm@cyrius.com>
3 ##
4 ## DP: Fix a off by one in relpath() [#334088]
5
6 @DPATCH@
7 --- bins-1.1.29.orig/bins
8 +++ bins-1.1.29/bins
9 @@ -1151,7 +1151,7 @@
10 my $l2 = length($p2);
11
12 my $cl = cls($p1, $p2);
13 -
14 + $cl-- if (substr($p2, $cl-1, 1) ne "/");
15 my $p2r = substr( $p2, $cl, $l2);
16
17 my $p1dc = 0;