comparison debian/patches/13_locale_encoding @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 13_locale_encoding.dpatch by Jérôme Sautret
3 ##
4 ## DP: convert latin-1 output to locale [#308111]
5
6 @DPATCH@
7
8 --- bins-1.1.29.orig/bins
9 +++ bins-1.1.29/bins
10 @@ -952,13 +952,23 @@
11
12 sub write_htaccess;
13
14 -print "\nBINS Photo Album 1.1.29 (http://bins.sautret.org/)\n";
15 -print "Copyright © 2001-2004 Jérôme Sautret (Jerome\@Sautret.org)\n";
16 -print "Some parts of code:\n";
17 -print "Copyright © 2000 Brendan McMahan (mcmahahb\@whitman.edu)\n";
18 -print "Copyright © John Moose (moosejc\@muohio.edu)\n\n";
19 -print "This is free software with ABSOLUTELY NO WARRANTY.\n";
20 -print "See COPYING file for details.\n\n";
21 +my $copyright=<<END;
22 +BINS Photo Album 1.1.29 (http://bins.sautret.org/)
23 +Copyright © 2001-2004 Jérôme Sautret (Jerome\@Sautret.org)
24 +Some parts of code:
25 +Copyright © 2000 Brendan McMahan (mcmahahb\@whitman.edu)
26 +Copyright © John Moose (moosejc\@muohio.edu)
27 +
28 +This is free software with ABSOLUTELY NO WARRANTY.
29 +See COPYING file for details.
30 +
31 +END
32 +
33 +my $latin2localConverter;
34 +$latin2localConverter = Text::Iconv->new('latin1',
35 +$defaultConfig{defaultEncoding});
36 +$copyright = $latin2localConverter->convert($copyright);
37 +print $copyright;
38
39 # EVG (Evil Global Variables)
40 # Some on them should be moved to the config hash so they can be