comparison debian/patches/14_bins-edit-gui @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
comparison
equal deleted inserted replaced
0:a84c32f131df 4:c5749e43b1d7
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 14_bins-edit-gui.dpatch by <rousseau@macbox.maison.bogus>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
6
7 @DPATCH@
8 --- bins-1.1.29.orig/bins-edit-gui
9 +++ bins-1.1.29/bins-edit-gui
10 @@ -38,8 +38,33 @@
11
12 use Getopt::Long;
13
14 -use Gtk;
15 -use Gtk::GladeXML;
16 +BEGIN {
17 + unless (eval "use Gtk; 1;") {
18 + push @p, "libgtk-perl";
19 + $fail=1
20 + }
21 +
22 + unless (eval "use Gtk::GladeXML; 1;") {
23 + push @p, "libgladexml-perl";
24 + $fail=1
25 + }
26 +
27 + unless (eval "use Gtk::Gdk::ImlibImage; 1;") {
28 + push @p, "libgtk-imlib-perl";
29 + $fail=1
30 + }
31 +
32 + unless (eval "use Gnome; 1;") {
33 + push @p, "libgnome-perl";
34 + $fail=1
35 + }
36 +
37 + if ($fail)
38 + {
39 + print "You need to install the Debian package(s): ", join(", ", @p), "\n";
40 + exit;
41 + }
42 +}
43
44 use XML::DOM;
45 use XML::XQL;