view debian/patches/14_bins-edit-gui @ 4:c5749e43b1d7

Adding debian files (to original 1.1.29)
author Peter Gervai <grin@grin.hu>
date Wed, 15 Oct 2008 23:35:35 +0200
parents
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 14_bins-edit-gui.dpatch by  <rousseau@macbox.maison.bogus>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: No description.

@DPATCH@
--- bins-1.1.29.orig/bins-edit-gui
+++ bins-1.1.29/bins-edit-gui
@@ -38,8 +38,33 @@
 
 use Getopt::Long;
 
-use Gtk;
-use Gtk::GladeXML;
+BEGIN {
+	unless (eval "use Gtk; 1;") {
+		push @p, "libgtk-perl";
+		$fail=1
+	}
+
+	unless (eval "use Gtk::GladeXML; 1;") {
+		push @p, "libgladexml-perl";
+		$fail=1
+	}
+
+	unless (eval "use Gtk::Gdk::ImlibImage; 1;") {
+		push @p, "libgtk-imlib-perl";
+		$fail=1
+	}
+
+	unless (eval "use Gnome; 1;") {
+		push @p, "libgnome-perl";
+		$fail=1
+	}
+
+	if ($fail)
+	{
+		print "You need to install the Debian package(s): ", join(", ", @p), "\n";
+		exit;
+	}
+}
 
 use XML::DOM;
 use XML::XQL;