Mercurial > bins
comparison debian/patches/21_bins-trim @ 4:c5749e43b1d7
Adding debian files (to original 1.1.29)
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Wed, 15 Oct 2008 23:35:35 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
0:a84c32f131df | 4:c5749e43b1d7 |
---|---|
1 #! /bin/sh /usr/share/dpatch/dpatch-run | |
2 ## 21_bins-trim.dpatch by <rousseau@imac.maison.bogus> | |
3 ## | |
4 ## All lines beginning with `## DP:' are a description of the patch. | |
5 ## DP: add -trim argument to jpegtran. | |
6 ## DP: Closes: #284157: bins: avoidable jpegtran image corruption | |
7 | |
8 @DPATCH@ | |
9 --- bins-1.1.29.orig/bins | |
10 +++ bins-1.1.29/bins | |
11 @@ -4894,7 +4894,7 @@ | |
12 if ($rotateJPEG eq "none") { | |
13 beVerbose("\n Looking for a JPEG rotation utility (jpegtran)... ", 3); | |
14 if (commandAvailable("jpegtran")) { | |
15 - $rotateJPEG = 'jpegtran -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; | |
16 + $rotateJPEG = 'jpegtran -trim -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; | |
17 beVerboseN(" found jpegtran.", 3); | |
18 } elsif (commandAvailable("jpegtran-mmx")) { | |
19 $rotateJPEG = 'jpegtran-mmx -copy all -rotate %s -outfile "%s.tmp" "%s" && mv "%s.tmp" "%s"'; | |
20 @@ -5001,7 +5001,7 @@ | |
21 if ($progressifyJPEG eq "none") { | |
22 beVerbose("\n Looking for a progressive JPEG utility (jpegtran)... ", 3); | |
23 if (commandAvailable("jpegtran")) { | |
24 - $progressifyJPEG = 'jpegtran -copy all -progressive -outfile "%s" "%s"'; | |
25 + $progressifyJPEG = 'jpegtran -trim -copy all -progressive -outfile "%s" "%s"'; | |
26 beVerboseN(" found jpegtran.", 3); | |
27 } else { | |
28 $progressifyJPEG = ""; |