Mercurial > bins
view debian/patches/09_fix_wrong_relpath @ 6:3021deef1599
Encoding related fixes
* chomp encoding string
* reformat else (seems someone hacked it in)
* debug print encoding
* do not use :utf8 binmode ("re-encode") on written file if the input is _already_ UTF-8
author | Peter Gervai <grin@grin.hu> |
---|---|
date | Thu, 16 Oct 2008 00:02:14 +0200 |
parents | c5749e43b1d7 |
children |
line wrap: on
line source
#! /bin/sh /usr/share/dpatch/dpatch-run ## 09_fix_wrong_relpath.dpatch by Martin Michlmayr <tbm@cyrius.com> ## ## DP: Fix a off by one in relpath() [#334088] @DPATCH@ --- bins-1.1.29.orig/bins +++ bins-1.1.29/bins @@ -1151,7 +1151,7 @@ my $l2 = length($p2); my $cl = cls($p1, $p2); - + $cl-- if (substr($p2, $cl-1, 1) ne "/"); my $p2r = substr( $p2, $cl, $l2); my $p1dc = 0;