view debian/patches/09_fix_wrong_relpath @ 11:8b62360dc2a5 default tip

Adding notes, cloning edit-gui
author Peter Gervai <grin@grin.hu>
date Sun, 02 Nov 2008 16:29:52 +0100
parents c5749e43b1d7
children
line wrap: on
line source

#! /bin/sh /usr/share/dpatch/dpatch-run
## 09_fix_wrong_relpath.dpatch by Martin Michlmayr <tbm@cyrius.com>
##
## DP: Fix a off by one in relpath() [#334088]

@DPATCH@
--- bins-1.1.29.orig/bins
+++ bins-1.1.29/bins
@@ -1151,7 +1151,7 @@
     my $l2 = length($p2);
 
     my $cl = cls($p1, $p2);
-
+    $cl-- if (substr($p2, $cl-1, 1) ne "/");
     my $p2r = substr( $p2, $cl, $l2);
 
     my $p1dc = 0;