comparison debian/dcc-client.postinst.diff @ 1:9b8d79ac0dc3

blindly adding debian patch for old version
author Peter Gervai <grin@grin.hu>
date Tue, 10 Mar 2009 14:25:08 +0100
parents
children
comparison
equal deleted inserted replaced
0:c7f6b056b673 1:9b8d79ac0dc3
1 --- dcc-1.2.74.orig/debian/dcc-client.postinst
2 +++ dcc-1.2.74/debian/dcc-client.postinst
3 @@ -0,0 +1,56 @@
4 +#! /bin/sh
5 +# postinst script for dcc
6 +#
7 +# see: dh_installdeb(1)
8 +
9 +set +e
10 +
11 +# summary of how this script can be called:
12 +# * <postinst> `configure' <most-recently-configured-version>
13 +# * <old-postinst> `abort-upgrade' <new version>
14 +# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
15 +# <new-version>
16 +# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
17 +# <failed-install-package> <version> `removing'
18 +# <conflicting-package> <version>
19 +# for details, see http://www.debian.org/doc/debian-policy/ or
20 +# the debian-policy package
21 +#
22 +# quoting from the policy:
23 +# Any necessary prompting should almost always be confined to the
24 +# post-installation script, and should be protected with a conditional
25 +# so that unnecessary prompting doesn't happen if a package's
26 +# installation fails and the `postinst' is called with `abort-upgrade',
27 +# `abort-remove' or `abort-deconfigure'.
28 +
29 +case "$1" in
30 + configure)
31 + if [ -x /usr/bin/dccproc ]; then
32 + chown dcc:dcc /usr/bin/dccproc
33 + chmod 04755 /usr/bin/dccproc
34 + fi
35 + if [ -x /usr/sbin/dccifd ]; then
36 + chown dcc:dcc /usr/sbin/dccifd
37 + chmod 04755 /usr/sbin/dccifd
38 + fi
39 +
40 + ;;
41 +
42 + abort-upgrade|abort-remove|abort-deconfigure)
43 +
44 + ;;
45 +
46 + *)
47 + echo "postinst called with unknown argument \`$1'" >&2
48 + exit 1
49 + ;;
50 +esac
51 +
52 +# dh_installdeb will replace this with shell code automatically
53 +# generated by other debhelper scripts.
54 +
55 +#DEBHELPER#
56 +
57 +exit 0
58 +
59 +